NOVEDADES:
Cargando...

Solucionado - Cómo conectar el chat de facebook en Pidgin de Linux


conectar el chat de facebook en Pidgin de Linux


En estos días se vé que hay muchos usuarios de Pidgin que han tenido problemas al conectarse al chat de Facebook. Es posible que es causa de las nuevas actualizaciones y modificaciones que ha hecho la compañía de Facebook sobre los protocolos de comunicación para integrar nuevas tecnologías y para mejorar la seguridad.

Una de la soluciones es esperar a que los desarrolladores de los clientes de chat incluyan la modificación para volver a trabajar con estos servicios. Otra solución es seguir los pasos que te voy a mencionar en seguida para instalar un complemento de Pidgin que se llama Purple-Facebook.


Siempre entrando como root con el comando: $ sudo su

1- Instalar las dependencias:

$ apt-get install libjson-glib-dev mercurial

2- Clonar el repositorio de purple-facebook:

$ git clone https://github.com/jgeboski/purple-facebook.git

3- $ cd purple-facebook

4- $ ./autogen.sh

La ejecución del autogenerador nos cogerá un poco de tiempo para descargar, entonces tenemos que esperar.

5- $ make para compilar lo descargado

6- $ sudo make install para instalar dichos paquetes

7- Reiniciar el Pidgin.

8- Ir a la sección de cuentas/gestionar cuentas

9- Asegúrate que tu cuenta de facebook este deshabilitada, una vez verificado presiona el botón modificar.

10- En protocolo eliges "Facebook"

11- En el campo de usuario borra: @chat.facebook.com y guarda los cambios.


4 comentarios: Leave Your Comments

  1. Hola, soy nuevo en linux, uso Lubuntu, hice todos los pasos, pero en estos:

    5- $ make para compilar lo descargado

    6- $ sudo make install para instalar dichos paquetes

    me dice que "root@desarrollo01:/home/eduardo/purple-facebook# make
    make: *** No se especificó ningún objetivo y no se encontró ningún makefile. Alto."

    podrías especificar bien los pasos 5 y 6 así puedo terminar el proceso ?

    Y en el paso 4: ./autogen.sh , cargó bastantes cosas pero me dió el siguiente error:

    root@desarrollo01:/home/eduardo/purple-facebook# ./autogen.sh
    pulling from https://hg.pidgin.im/soc/2015/jgeboski/facebook
    searching for changes
    no changes found
    resolving manifests
    0 files updated, 0 files merged, 0 files removed, 0 files unresolved
    patching file libpurple/protocols/facebook/Makefile.am
    patching file libpurple/protocols/facebook/Makefile.mingw
    patching file libpurple/protocols/facebook/facebook.c
    patching file libpurple/protocols/facebook/facebook.h
    patching file libpurple/http.c
    autoreconf: Entering directory `.'
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal --force -Im4
    autoreconf: configure.ac: tracing
    autoreconf: configure.ac: creating directory build-aux
    autoreconf: configure.ac: not using Libtool
    autoreconf: running: /usr/bin/autoconf --force
    configure.ac:34: error: possibly undefined macro: AC_DISABLE_STATIC
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    configure.ac:35: error: possibly undefined macro: AC_PROG_LIBTOOL
    autoreconf: /usr/bin/autoconf failed with exit status: 1

    ResponderEliminar
    Respuestas
    1. Hola +Eduardo Servin , gracias por pasarte por aquí..

      Muy probable, tienes problemas en el paso 4 al no tener algunos paquetes instalados en el sistema operaivo.. Son el Gettext y Libtool.. Intenta instalarlos y haber si te soluciona el problema que has tenido antes.

      Eliminar
  2. Hola +Eduardo Servin , gracias por pasarte por aquí..

    Muy probable, tienes problemas en el paso 4 al no tener algunos paquetes instalados en el sistema operaivo.. Son el Gettext y Libtool.. Intenta instalarlos y haber si te soluciona el problema que has tenido antes.

    ResponderEliminar
  3. Package requirements (purple < 3) were not met:

    No package 'purple' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables PURPLE_CFLAGS
    and PURPLE_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    que puedo hacer?

    ResponderEliminar